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There can be some screen images with an old interface, the toolbar layout has been 
slightly reorganized, but the functionality remained the same. 



 

1. 2D window 
 

The main window - will be called “2D view” 
 

 
 

Interface 
 

Buttons 
The upper row: 
- Zoom in – click to zoom in. 
- Zoom out – click to zoom out. 
- New mesh – create a new empty mesh with all the properties set up in the mesh 

properties window. 
- Reset – remove the current mesh from the program. 
The bottom row 
- Move – move the mesh – when this button is pressed move the mesh to the 

desired location by left-click and dragging the mesh. 
- Enlarge – when the button is pressed select the area to enlarge by left-click and 

dragging the mesh. 
- Fit to the screen – clicking this button fits the current mesh to the screen. 

 
“All ” checkbox – draw all meshes at once. 

 
“3D view” button – send the current mesh to the 3D view, opens a new window 
where the 3D model of the mesh is displayed. 



“Switch mesh” button – switch between meshes if there is more than one mesh 
loaded to the program. 

 
All the checkboxes on the right side are used to set which mesh features are going to 
be displayed. 

 
 

a. Before making a new mesh – setting mesh properties 
 

Using the “File->New mesh properties” menu option the user can specify properties 
of a new mesh to be created – type of the mesh, the bounding box of the mesh, disk 
radius for all points and the big triangle points elevation value.  
 
Bounding box – it is a rectangle inside which points can be added, it specifies the 
maximum range of the data. 
 
All points are enclosed by “a big triangle” containing the bounding box inside.  
 
Disk radius (DR) – each point has its own zone around called disk with the radius 
specified. All points in the mesh have the same disk radius – disk radius is set for the 
whole mesh. The distance between any two points cannot be smaller than two times 
the disk radius value 2*DR. If a new point is going to be inserted in a location where 
there is a point within 2*DR distance then this case is called a collision and the point 
will not be inserted. 
There are two buttons allowing quick change of the disk size: “*10” – increasing the 
size 10 times, and “/10” – decreasing the size 10 times. 

 
Mesh types: 
1. Delaunay 
2. Delaunay for Flow Simulation, we will call it “Mesh Flow Delaunay” 
 
All settings set by the user in this window will be applied to every mesh created 
afterwards. 
 



 
 

A new mesh can be created in 3 ways, using the “File” menu, each new mesh has all 
the properties set up in the “New Mesh Properties” window: 
1. New mesh – creates a new empty mesh and points can be inserted manually. 
2. Mesh from a file with points – reads points from the “*.pts” file and inserts them 

into the mesh. 
3. Mesh from a shapefile – reads points from “*.shp” file and inserts them to the 

mesh. 
At any time another data set can be loaded into the current mesh by choosing “Add 
another data to the mesh...” from the File menu. 

 
b. Program modes 

 
After the mesh is created the 2D window of the program is in the “General” mode.  In 
this mode clicking inside the window does not give any effect.  

 
The current mode is displayed on the bottom of the window in the third part of the 
Status Bar. 

 



 
 

Switching between modes can be achieved by selection in the pop-up menu, which 
appears by Right-Click with Ctrl button pressed. This pop-up menu differs for each 
type of the mesh. In each of those modes user can perform some operations on the 
current mesh. 

 
Modes Available if the mesh type is Delaunay: 
- Insert 
- Delete 
- Assign elevation - crust 
- Assign elevation - point 
- Crust - Connect Two Points 
- Insert Point Between Two Points 
- Insert Line 

 
If the mesh type is Flow Delaunay then some additional modes available: 
- Set Constant Head  
- Add Water 
- Set No Flow Data Point 
- Set Monitoring Point 
- Set the outlet for cumulative catchment areas 

 
The menu below is displayed for Mesh Delaunay. 



 
 

The menu below is displayed for Mesh Flow Delaunay. 

 
 
Press ESC to return to the general mode. 
 

c. Operations 
 

If the mesh exists following operations are available: 
- Insert a new point – “I” key - change the program mode to “Insert” – Ctrl+Right-

Click opens the pop-up menu where you must select “Insert” field, another way to 
enter “Insert” mode is to press “i” key. In that mode Left-Click causes insertion of 
a new point at the selected location. Right-Click opens a small window, in which 
you can specify the elevation value for the new point. The current elevation value 
is displayed in the second part of the Status Bar at the bottom of the window. 



- Delete a point – “D” key - change the program mode to “Delete” – Ctrl+Right-
Click opens the pop-up menu where you must select “Delete” field, another way 
to enter “Delete” mode is to press “i” key. In that mode Left-Click causes deletion 
of a node nearest to the selected location. Elevation of the nearest node is 
displayed at the bottom of the form. 

- Assign an elevation for contour lines – “A” key - change the program mode to 
“Assign elevation - crust” - Ctrl+Right-Click opens the pop-up menu where you 
must select “Assign elevation - crust” field. In this mode when you move the 
cursor over the data the closet contour line made of crust edges is being 
highlighted, Right-Click opens a small window where you can specify the 
elevation you want to assign to a contour line. Left-Click starts the assigning 
elevation process, which follows the crust starting from the closest data point. The 
current elevation value is displayed in the second part of the Status Bar at the 
bottom of the window. In the first part of the status bar the elevation of a nearest 
node to the cursor is displayed. 

- Assign elevation for a single point – “P” key - change the program mode to 
“Assign elevation – point” - Ctrl+Right-Click opens the pop-up menu where you 
must select “Assign elevation - point” field. In this mode when you move the 
cursor over the mesh the closet data point is being highlighted, Right-Click opens 
a small window where you can specify the elevation you want to assign to the 
point and Left-Click changes the elevation value of the selected data point. The 
current elevation value is displayed in the second part of the Status Bar at the 
bottom of the window. 

- Connect two selected points by crust edges – “C” key - change the program mode 
to “Crust - Connect Two Points”, then when you move the cursor over the mesh 
the closet data point is being highlighted. You need to select the first and the 
second point with Left-Click, after the second selection those two points will be 
connected automatically with crust edges. 

- Insert a new point exactly in the middle of two selected points – “B” key - change 
the program mode to “Insert Point Between Two Points”, then when you move 
the cursor over the mesh the closet data point is being marked. You need to select 
the first and the second point with Left-Click, after the second selection a new 
point between those two points will be automatically inserted. Its elevation will be 
computed using elevation of used two points. 

- Insert a line – “L” key - change the program mode to “Insert Line”, then insert 
two points – after insertion of the second point some additional points will be 
inserted between those two points if required and a line made of triangle edges 
will be created. 

 
 

d. Working with several meshes 
 

The program allows working with more than one mesh. Another mesh can be added 
at any moment in the same way as the first mesh – just by reading a file or like a new 
empty mesh. The mesh loaded as the last one and being displayed on the screen we 
will call “the current mesh”.  



 
All the meshes are displayed at once if “all” checkbox is ticked. 
 
Switching between meshes can be achieved by clicking on “Switch mesh” button or 
by pressing F1 key. Then a window with the list of meshes is displayed and the user 
can choose a mesh he wants to be a current mesh. Each mesh can be identified by the 
name of the file used to create the mesh. If the mesh was created not from a file but as 
a new mesh then instead of the name of the file a “new mesh” text is displayed. 
Clicking RESET button removes the current mesh from the set of meshes and sets 
another mesh as the current one. 

 
3D view allows displaying more than one mesh also. To display more than one mesh: 
- Load the first mesh data, click 3D view button to send the mesh to 3D view. 
- Switch to 2d view without closing the 3d view – click onto the 2D view form or 

choose from the menu “Display – Switch” to 2D option 
- Load another data and click 3D view button again to send the second data set to 

3D. Each mesh can be manipulated separately in the 3D – select the mesh (press 
Select button and left-click onto the mesh) and being in the selection mode enter 
the manipulation mode. 

- Switch to 2D view and load another data set.  
 
Removing a mesh from 2D removes this mesh from 3D automatically. If the last 
mesh is removed from 2D view then the mesh is removed from the 3D view and the 
3D view window is being closed automatically. 

 
Loading the data, sending it to 3D and switching back to 2D (without closing 3D) 
and then modifying the data the way than data ranges will change (new x,y or z 
minimum or maximum values) and sending the same mesh with the data modified 
leads to obtaining the same 3D view – the mesh will not be rescaled.  
But loading the data, sending it to 3D view, closing the 3D view, modifying the data 
in 2D and sending it to 3D again leads to obtaining a different 3D display than before 
– all the data will be rescaled to fit to the 3D window. 

 



 
 
 

e. The main menu: 
 
- File 

·  New mesh properties – properties of the mesh to be created. 
·  New mesh – to create a new mesh. Creates a big triangle (with elevation values 

taken from “New mesh properties” window), which is a frame for the mesh. New 
points can be inserted only within the mesh’s bounding box drawn in the middle 
of the big triangle. 

·  Reset – delete the current mesh, everything is deleted from the memory, the same 
action when “RESET” button is clicked. If there was more than one mesh then 
another mesh is becoming the current one. 

·  Mesh from a file with points – to create a mesh from a file with points. “Open 
file” dialog is displayed. After the file is selected the mesh is created (with 
properties set up in “New Mesh Properties”) and displayed. 
Files with points have “pts” extension. These are text files, containing points 
coordinates, each line contains three values - x,y and z coordinates. Also the mesh 
bounding box can be stored in the pts file – as four double values in the first line 
of the file – x min, y min, x max, y max values. 

·  Mesh from a SHP file – to create a mesh from ESRI shp file. Shapefile z values 
are stored in dbf file. The associated dbf file’s fields are displayed one by one in a 
message box and the field containing z value has to be selected. 

 



·  Mesh from a bitmap with contours – to create a mesh from a bitmap containing 
contour lines. The field is enabled after the bitmap is loaded. The mesh bounding 
box size is equal to the bitmap size and for each black pixel a new point is 
inserted. 

·  Save points - *.pts file – to save current triangulation nodes in a pts file, “Open 
file” dialog is shown. 

·  Save points – ArcView *.pnt file – to save current triangulation nodes in a pnt 
file, “Open file” dialog is shown. Pnt files can be read in ArcView. 

·  Save triangles in txt file – to save the current triangulation in a file containing a 
triangle coordinates in each line. 

·  Save as GRID – to create a grid from the triangulation. Firstly “Grid 
interpolation” window is displayed with gridding options. 

 
Five types of grid files can be created –USGS DEM file (*.dem), ASCII grid file 
(*.txt), ASCII ArcView file (*.asc), (*xyz) and (*.grd). An interpolation method 
has to be selected, slopes or smoothing options can be selected too. The each 
value can be rescaled also with value specified in “scale” field. After setting all 
grid properties “Save file” dialog window is displayed, where the user has to input 
the name of the file and select a location to save it. 
After changing values in editing fields press Enter to recalculate all other values. 

·  Save mesh in BMP file – to save a mesh as a bmp image. 
·  Exit – to close the program. 

- Image 
·  Load bitmap – to load an image containing contour lines. 
·  Save bitmap – to save the current image. 
·  Remove bitmap – to remove the bitmap from the program. 
·  Prewitt edge detection – to process the image, edge detection using Prewitt 

algorithm. 
·  Sobel edge detection – to process the image, edge detection using Sobel 

algorithm. 
·  Thinning – to thin image features. 



·  Extract Separate Pixels – to extract pixels from the lines. Uses number of white 
pixels around each black pixel specified in “Bitmap properties” dialog window. 

·  Inverse bitmap – to change colours of the image. 
·  Black for non-white – to change colours of non-white pixels to black. 
·  Enlarge bitmap 2x – to enlarge a bitmap twice. 

- Skeleton functions 
·  Estimate Skeleton Vertices Elevation - valley length – to estimate skeleton 

vertices elevation using constant slope down the valley method. 
·  Estimate Skeleton Vertices Elevation – Radius – to estimate skeleton vertices 

elevation using constant side wall slope method. 
·  Estimate Skeleton Vertices Elevation - Radius - Distance – to estimate skeleton 

vertices elevation using mixed method. 
·  Estimate crust nodes elevation based on the distance from selected node – for 

river data, the user has to select the outlet point of the river, elevation will be 
assigned automatically for all crust points starting from that point 

·  Enrich TIN with Skeleton – to insert skeleton vertices into existing TIN. 
·  Enrich TIN with Skeleton – River Network – to enrich the TIN with skeleton 

vertices. All TIN vertices have z value equal to 0 (river basin), and skeleton 
vertices will have their elevation estimated based on radii of circumcircles of 
triangles. (try this option with river.pts file) 

- Generalization 
·  Move one point onto parent circle – to retract simple skeleton branches, using 

method from Thibault, Gold paper on skeleton generalization. 
- Grid 

Grids are associated with meshes. Each mesh can have its own grid created by 
interpolation of this mesh. To create a grid “Make grid” option has to be used. 
Making a grid without removing the previous one replaces automatically the old grid 
with the new one. The program allows work with more than one grid – each mesh can 
contain its own grid. All grid operations like drawing histograms or computing 
curvatures are performed on the current mesh’s grid. 
·  Make grid – displays “Grid interpolation” window, where the interpolation 

method, grid size and other parameters can be set. To model grid based runoff 
“Flow grid” checkbox has to be checked – auxiliary grid for runoff will be created 
then. After grid is created it is stored in the memory – in the second status bar at 
the bottom of the window “Grid” text is displayed. If Flow grid was created too, 
then the text at the bottom is “Grid + Flow Grid”. Grid cells are being drawn 
when “Draw grid” menu field is checked.  The same is about grid nodes and grid 
cells values. 



 
·  Grid from ASCII ArcView grid (*.asc)...- to make a grid from an ASC ArcView 

grid file. It creates a new mesh having the size equal to the size of the grid and 
with nodes inserted in the middle of each cell of the grid. Voronoi Diagram of this 
mesh has squared Voronoi cells and looks exactly like the grid. 

·  Grid from ASCII GS file (*.grd)... – to make a grid from a Surfer grid file. A 
mesh based on the grid is created automatically. 

·  Grid from ASCII TXT file (*.txt)... - to make a grid from a TXT ASCII grid file. 
A mesh based on the grid is created automatically with the bounding box set up in 
the “Mesh New Properties” window. Grid TXT files do not contain any 
information about the grid’s data range, they contain only z values, that is why the 
user has to specify the size of the grid before reading this kind of grids. 

·  Delete Grid – to remove the grid from the memory. 
·  Grid properties – displays “Grid properties” windows, where grid parameters are 

displayed and some parameters can be set. 

 
·  Calculate and Draw Slopes – if the grid exists then slopes are calculated and 

drawn on the screen. 
·  Calculate and Draw Profile Curvature – if the grid exists then profile curvature is 

calculated and drawn on the screen. 



·  Calculate and Draw Plan Curvature – if the grid exists then plan curvature is 
calculated and drawn on the screen. 

·  Profiles histogram –  
·  Relative heights histogram –  
·  Slopes distribution histogram – “Slope distribution” window is shown, number of 

slope classes has to be specified and the histogram is drawn (slopes here is 
measured in degrees, possible values are between 0 and 90 degrees, slopes are 
classified into classes). 

·  Profile curvature distribution histogram –  
·  Plan curvature distribution histogram –  
·  Compare two grids volumes – if grids are created for two or more meshes then 

their volumes can be compared, it compares the current grid with the next one. 
·  Draw grid – when this menu field is checked a grid cells are drawn. 

 
·  Draw grid points – draws points within grid cells. 

 
·  Draw grid z values – draws each cell’s elevation value. 

 
 

- Additional points 
·  Random – to insert a specified number of points in a selected area randomly 

distributed. 

 



·  Grid – to insert a specified number of regularly distributed points in a selected 
area (grid pattern). Number of columns and rows has to be specified. 

 
·  Circle – to insert a circle with specified centre, radius or specified number of 

circles with the same centre, specified radius difference. 

 
·  Random Voronoi Pattern – to insert randomly distributed additional points. 
·  Thicken points on crust edges– to insert additional points on crust edges (based on 

the disk size). 
·  Add another data to the mesh – to add points from another file with points to the 

current mesh. 
·  Add another data to the mesh preserving volume – to add points from another file 

with points to the current mesh, only x any coordinates will be used, the altitude 
of additional points will be calculated during insertion to preserve the initial 
volume of the mesh. 

·  Frame around mesh bounding box – to insert points outside the bounding box to 
frame the mesh. Additional dialog box “Frame around mesh” is being displayed 
after choosing this option and the number of frame points and the elevation value 
has to be specified there. 

- Runoff – enabled if the mesh is Flow Delaunay 
·  Properties – runoff properties. Runoff process parameters have to be specified in 

this dialog.  



 
·  Add Flow Frame – adds a flow frame to TIN. Points in the flow frame have 

spacing values defined in “Runoff properties” dialog. Their z values are taken 
from “z edit field”. 

·  Draw Runoff – this field can be checked, if checked then during runoff process 
water flow is drawn. 

·  Initialise Runoff –initialises the runoff. A certain amount of water, specified in 
“Runoff properties” dialog “initial water height” field is put to every Voronoi cell. 

·  Remove Water – to remove water from all cells, sets the model as not initialised. 
·  Start Voronoi Runoff – to start Voronoi runoff process. Performs i iterations, 

where i is specified in “Runoff properties” dialog in “iterations” field, the screen 
is repainted every n-iteration and n is specified in “Runoff properties” dialog in 
“repaint every n-th iteration” field. 

·  Start Grid runoff – to start runoff on grid. 
·  Save Runoff in BMP file – to save current flow state as an image. 
·  Draw runoff – draw Vornoi celss filled with water 
·  Draw water level – draw the level of water in each cell 
·  Draw water volume – draw the volume of water in each cell 
·  Water level Monitoring Chart – displays a chart showing the amount of water at 

the constant head point at specified iterations. If there is more than one constant 
flow point then it monitors only the first one. 

·  Water volume output chart -  
- Options 

·  Set Constant Intervals – when this menu field is checked, snapping is turned on 
while insertion new points – current x and y coordinates are changed to the 
nearest integer values. 

·  Display options – displays “Display options” window, where colours and some 
other features can be adjusted. 



 
·  Bitmap properties – displays “General properties” window, where some other 

settings can be changed – output bitmap size and number of white pixels used to 
perform “Reduce shape” Image function. 

 
·  Mesh info – displays “Mesh Info” window, where mesh type and mesh size is 

displayed. 

 



·  Rescale mesh view – custom scaling. 
 

- Auxiliary (stuff mostly under development) 
·  Even out z values using NEM – to smooth out the surface using Natural Element 

Method of interpolation. 
·  Create new mesh by sampling this mesh – to regularly sample the data, x and y 

steps have to be specified. A new mesh will be created automatically and it will 
become the current mesh. 

 
- About – an information window 
 
 



2. 3D window 
 

 
 

a. Menu and toolbar 
 

“Display” group – two ways of displaying the model, can be switched at any 
moment: 
- Triangles 
- Cells – Voronoi cells associated with nodes 

 
“Edges” checkbox – when it is checked then edges of triangles or cell are displayed. 
It slows down the displaying significantly – it the computer is not fast enough then 
manipulation of the model with edges displayed is very slow – the solution then is to 
manipulate the model without displaying the edges and displaying the edges after 
finishing the manipulation. 

 
“Scale” button and editing field – to rescale the data, after clicking Scale button all z 
values in the model are multiplied by the value taken from the editing field. 
 
“Coordinates” group  – when ON button is pressed then the current world 
coordinates are displayed while the cursor is being moved above the current model. 
(when more than one mesh is being displayed in 3D it may not work properly, under 
development) 
 
Main menu 
- File - Save as OBJ file – to save the object as OBJ file. 
- File - Load texture – to load a texture from a bmp file. 
- File - Make and load texture – creates and loads a texture from the current 2d 

view. The texture size is set up in “Display-Bitmap properties” in the main 
program window. The size of the bitmap must be set a power of 2, like 256x256, 
512x512. The shape of the bounding box of the mesh does not have to be squared 
- the texture will be adjusted to the model automatically.  



- Display – Flat triangles – when triangles are displayed marks all flat triangles in 
the model. 

- Display – Axes – draws x, y and z axes 
- Display – Switch to 2D – open the 2D window, without closing the 3D one 
- Display – Options – some settings: size of edges, position of the light in the scene 
- Display – Cumulative catchment areas – to display bars of the water volume 
- Display – reset view – go back to the initial view 
- Display – Rescale – rescale the model 

 
If the current mesh is Mesh Flow Delaunay then some additional features are 
displayed in the toolbar – the Runoff box. 
 

 
 

b. 3D window working modes 
 

Several different working modes: 
- General 
- Manipulation 
- Selection 
- Terrain operations – insert and connect 
 
The general mode  
Movement of the mouse cursor and left-button clicking inside the window doesn’t 
make any effect. Right click – switching to the manipulation mode. Right click again 
- return to the general mode. 

 
The manipulation mode – the cursor is not visible 
- Mouse movement – x and z axes rotation of the whole view or the selected mesh. 
- Mouse movement with the mouse left button pressed – change the position of the 

viewer – impression of moving the model.  
- Mouse wheel – zoom in or zoom out the whole view or the selected mesh. 
 



Selection mode 
Another possible option is a selection of triangles or cells.  
- Select button – when this button is pressed then selection is performed by left-

click on the model, selected feature is marked in red. Entering the manipulation 
mode while something is selected means that all manipulation operations will be 
applied to the selected model – it is useful when more than one model is displayed 
at once in the 3d view. 

 
Terrain modification mode 
It is possible to delete nodes or to connect selected nodes in the 3d view.  
1. Delete button – when it is pressed then while moving the cursor the nearest node 

is marked by a small sphere and the left button clicking removes this marked 
node. 

2. Connect button – to connect two nodes. When this button is pressed the user has 
to select the first node by left-click and then select the second node – then those 
two nodes are being connected automatically by insertion of some additional 
nodes. 

 
c. Draping a picture onto a terrain 

 
Three ways: 
 
a) Use an image stored in a bitmap file.  

 
The bitmap image must be square-shaped and its size is limited to values being the 
power of 2, so it could be 64x64, 256x256, 512x512 and others. 

 
In the 3D view from the menu choose File->Load texture… Choose the bitmap file 
containing an image you want to use – the image will be draped on the mesh and this 
menu field will be checked.  To remove the texture uncheck the “Load texture” menu 
field. 
 
 

b) Create a bitmap image from the current mesh view in the program, save it and drape 
it on the model. 

 
Load the data to the program: File -> Mesh from a file with points… Select the file - 
for example “contours.pts”. The mesh is created (*). Choose features you want to 
display, for example only the crust and skeleton (**). 
 



* **  
 
Save the current mesh as a bitmap. File -> Save mesh in BMP file…. Choose a 
location for the file. The size of the saved picture has is 256x256 pixels. To change 
the size of the bitmap - from the main menu choose: Options -> Properties…  

 
 

You can change also colours and the size of lines and points – from the main menu 
choose: Options -> Display options… It opens the “Display Properties” where you 
can modify current colour and size settings of the displayed mesh features. 
 
View the mesh in 3D – click “3D view” button. To drape the picture choose File-
>Load texture… option from the menu. Choose the bitmap file with the texture - the 
picture is draped and this menu field is checked. To turn off the texture uncheck 
“Load texture” menu field. 

* **  
 



 
c) The image can be created and draped automatically from the current mesh. 
 

You can drape an image on the displayed 3d model automatically without creating a 
bitmap before. In 3d view menu there is an option “File->Make and load texture” 
which creates a texture from the current mesh displayed in the main program window 
– 2d view. It saves the current state of the mesh with all features like edges, skeletons 
or nodes displayed on the screen. Just click at this menu option and the bitmap will be 
created and draped on the 3d model. 

  
 
 



3. TIN from scanned contours 
 
Load an image with contour lines. Image should be stored as a bitmap with *.bmp 
extensions. To load a bitmap from the main menu choose: “Image -> Load bitmap…” 
Select a file you want to use – here “contours1 – 256x256.bmp”. The image will be 
loaded and displayed in the middle of the screen – it cannot be enlarged or moved. The 
bitmap should be a square with the size being the power of 2, like 256x256 or 512x512 
(to be able to drape it on the terrain model in 3D). If the image cannot be loaded open it 
in Microsoft Paint and save it as a 24-bit bitmap there. 
 
Image -> Load bitmap 

 
 
In order to create a TIN from the loaded bitmap containing contour lines the image has to 
be processed. 
 

a. Image processing 
 
The image should be in “black and white” format - from the main menu choose: “Image -
> Black for non-white”. It filters the image, giving back colour to all dark pixels and 
white colour to pixels having light grey colour (to remove some noise around lines in 
images created from JPEG).  
 
Image -> Black for non-white 

 
 
All contour lines should be one pixel width so they should be thinned - from the main 
menu choose: “Image -> Thinning”. 



 
Image -> Thinning. 

 
 
The separated pixels should be extracted from the lines – contour lines should be changed 
to dotted lines. It means some of neighbouring black pixels around some selected black 
pixels should be replaced with white pixels – from the main menu choose: Image -> 
Reduce shape. 
Default number of white pixels around black pixels is 2 but it can be changed – to do so 
from the main menu choose: “Options -> Bitmap properties…” 
 
Image -> Extract Separate Pixels 

 
 
After separated pixels are extracted from the contour lines the mesh can be created. By 
default the size of the mesh will be the same as the size of the image and for each black 
pixel one point will be inserted to the mesh.  
 

b. Mesh generation 
 
In order to create a mesh from the image in the main menu choose “File -> Mesh from 
contours bitmap…” A dialog window “Mesh from a bitmap with contours” will be 
displayed. 
 



 
 
In this window you can specify the disk size and the elevation value will be assigned to 
every inserted point. 
After confirming (OK button) the mesh is created. A node is inserted to the mesh at 
every non-white pixel location. 
 

  
 

 
 
You can save the current mesh in a *.pts file and use it in case if you do something wrong 
later… (File -> Save points…) to reconstruct the previous mesh shape without doing the 
all image processing again. 
 

c. Mesh generalization  
 
There are many skeleton branches consisting of only one Voronoi vertex, these branches 
can be removed by simple generalization of the skeleton. From the main menu choose 
“Generalization -> Move one point onto parent circle”. All simple skeleton branches are 
retracted and skeleton is much simpler - less “hairy”. 



 
Before      After 

  
 
Before the generalization  After Generalization 

   
 
 
 

d. Contour lines elevation assignment 
 
In the mesh created from the image every data point has the same z value – new z values 
has to be assigned by the user semi-manually. The idea of the assigning elevation process 
is to specify the elevation value and select a contour line - then the elevation value will be 
automatically assigned to all points belonging to the same contour line made by crust 
edges.  
 
Before starting this process all contour lines (consisting of crust edges) should be 
separated – if some of them are connected then manual modification of data points 
(insertion or deletion) should be performed until all contour lines are separated. 
 
The only case, when crust edges from different contours can be connected is on the 
border of the mesh, where crust border edges are allowed.  
 
Edges belonging to the crust and having both vertices connected to the big 
triangle will be called border crust edges.  
 



In cases of finding border crust edges the user will be asked, whether an approached 
border crust edge should be considered as a part of the current contour line and the 
process should be continued in this direction, or whether the process should treat this 
edge as the end of the contour line 

  
Those have to be marked manually as skeleton edges 

 
Crust edges on the border being a part of a contour, those have to be confirmed as crust 
edges. 
 

  
Not correct crust edge – one of 
 
To start assigning elevation values: switch the program to “Assign elevation - Crust” 
mode 
·  press ‘a’ key  



·  or ‘Ctrl+Right-Click’ to enter the pop-up menu and select ‘Assign elevation - Crust’ 
option 

 
In this mode Right-Click shows a window where the elevation has to be specified for the 
next contourline. 
 
 
 

 
 
After the elevation value is set up the user has to select any point belonging to the 
contour (made of crust edges) by Left-Click. The elevation will be assigned to all points 
connected to the selected point by crust edges. 
 
The boundary crust edge case – the user has to decide whether the boundary crust edge 
(thick edge marked in red and blue colour) should be considered as a part of the contour 
line. 

  
Some border crust edges are parts of contours (the right image) 
 
The current state of the mesh can be viewed in 3d by clicking “3d view” button. 



 
 
Resulting mesh, after assigning elevation values to all contours 

 
 
 
3d view of the resulting mesh 

  
 
After assigning all the elevation values the mesh should be saved in pts file. 
 



e. TIN enrichment 
 
In order to remove flat triangles from TIN skeleton vertices are used. Elevation values 
have to be assigned to skeleton vertices before their insertion.  
To be able to estimate skeleton vertices elevation every data point has to be connected  

·  to two another data points having the same elevation by two crust edges 
(data point inside the contour line). The only exception is on the boundary. 

·  or else to one data point by a crust edge and to the big triangle around the 
mesh (data point at the end of the contour line) 

It means that the crust and skeleton have to fulfil following conditions: 
1. All contour lines should be separated - it means that there can be maximum two crust 

edges connected to every data point.  
The only exception is allowed on the border of the map – in case of a border crust 
edge the user will have to decide whether that edge is a part of the contourline or not. 

2. None of the contour lines can be broken by any skeleton edge - every contour line 
must be a set of connected crust edges. (Crust contour lines are broken mostly when 
the distance between two data points is too large and when two contour lines are too 
close to each other. In other words every last segment of a contour line has to be 
connected to the frame (contour lines can be cut only on the border).  

3. There are not any single points inside the mesh. 
 
 
Flat triangles 

  
 

 
 



 
·  Skeleton vertices height estimation 

 
To start the process in the main menu the user should select “Skeleton functions -> 
Estimate Skeleton Vertices Elevation Using Radius” function. This function firstly tests 
whether the contours are correct, and if they are correct elevation values are 
automatically assigned to skeleton points. 
 
Skeleton vertices height estimation can be performed only when the crust and skeleton 
are in the correct form. If the crust or skeleton is not correct the program will mark 
incorrect parts and display “the crust and skeleton are not correct – modify it” text in the 
status bar at the bottom of the form. In the case when it is not sure whether the crust is 
correct (cases of border crust edges connecting different contour lines) the user will have 
to decide about it.  
 

 
 
Uncertain cases – in the case of border crust edges the user has to decide whether the 
crust edge is a part of a contourline or not – a yes/no dialog box ‘mark it as CRUST?’ is 
displayed – if user answers yes then a certain edge will be treated as a crust edge (a 
forced skeleton edge, geometrically still a part of the crust, but will be marked and 
consider as a part of the skeleton) 



 
 
 

  
   
If the result of ‘the contours correctness’ test was negative, the user has to modify the 
crust manually by point insertion or deletion.  
 
So, in other words, to be able to perform the estimation skeleton vertices elevation 
process every data point has to be connected either  

·  ‘to two another data points by two crust edges’  
·  or ‘to one data point by a crust edge and to the big triangle’.   

It means that: 
a) no single data points can exist in the mesh (Fig a1,a2) 
b) every contourline endpoint should be connected to the big triangle frame (Fig 

b1, b2 and b3, b4) 
c) none of the contourlines can be broken by any skeleton edge, every 

contourline must be a set of connected crust edges. (Crust contourlines are 
broken mostly when the distance between two data points is too large and 
when two contourlines are too close to each other (Fig c1, c2)) 

d) crust junctions cannot exist at any of the data points (Fig d1, d2). They are 
permitted temporarily as the border crust edges, but then they have to be 
marked as skeleton edges. 

Also every point of any contourline has to have the same z value. 
In the most of cases manual modifications of the crust and skeleton are required to meet 
the condition mentioned above.  
 
Make sure, that the z value of a point being inserted is the same as the z value of the 
currently modified contourline. 
 
Examples (from the old version of the program) 
 



a1  a2  
 a1  -  not correct – single data point 
 a2 - correct – single data point deleted 
 

b1  b2  

b3  b4  
b1, b3  -  not correct – contourlines endpoints are not connected to the big frame 
b2, b4 - correct – all conourlines endpoints connected to the big triangle frame 

 



 c1  c2  
 c1  -  not correct – a contourline is broken by the skeleton 

c2 - correct –crust edges of every contourline are connected 
 

d1  d2  
 d1 – not correct – 3 crust edges at a junction 

d2 – correct – every data edge “inside” contourlines connected to two 
neighbouring data point by crust edges 

 
 
more examples: 
 

  
Two connected contours - some points with an appropriate elevation value (in this case 
only one was needed) should be inserted on the edges adjacent to the crust edge 
connecting two contours. 



 

  
The endpoint of the contour is not connected to the big triangle – an additional point has 
to be inserted. 
 

  
Broken contours – endpoints are not connected to the big triangle – some points should 
be inserted between those two endpoints – in this case one is sufficient. 
 

  
Three crust edges connected to one data point – contour branches are not acceptable – the 
branch has to be removed by deletion of the endpoint. 
 



  
A single point in the corner, the solution is to add another point so a crust edge would be 
created. 
 
During the modifying process the user can check whether the data is already correct, just 
by trying to estimate elevation again (“Skeleton functions -> Estimate Skeleton Vertices 
Elevation Using Radius”). 
 
Before – many border crust edges, some of them are correct, being parts of contours, 
others connecting different contours are not correct and have to be marked manually as 
skeleton edges. 

 
After marking some of the edges as skeleton edges. 



 
 
 
More examples of the manual mesh modification 
 
Example 1: 
 

  
Three bottom crust boundary edges have to be set as skeleton edges (‘Yes’ answer to 
‘mark it as skeleton?’ question) 
 
Example 2: 



 
The crust in the middle is not connected to the big triangle – there is a thin triangle 
connecting endpoints of three contourlines. 
 

 
A corrected mesh after insertion of several points on the boundary. The long crust edge 
can be marked as a skeleton edge. 
 
Example 3 

 
Not correct mesh, the crust edge in the bottom left corner is not connected to the big 
triangle. 
 



 
Corrected mesh with some additional points added. 
 
Example 4 

 
Not correct mesh – contourlines not connected to the big triangle. 
 

 
Corrected mesh after insertion of three points. 
 
After cleaning the crust the assigning elevation process can be started. 
 
 
 

·  Skeleton points insertion 
 
After modifying the data, if the crust and skeleton are correct, then the estimation process 
can be performed. All elevation values are assigned automatically, and the skeleton 
points now can be inserted to the TIN model – “Skeleton Functions -> Enrich TIN with 
Skeleton”. 
 
 



  
Before      After 
 
In the enriched TIN points outside the border are skeleton points that were outside. They 
are inserted in the model because they are necessary to remove flat triangles existing on 
the border. The resulting TIN with those outside border point in 3D looks a bit confusing 
at the beginning, but in the interpolated terrain they don’t need to be included – just 
terrain inside the previous border is used. 
 

 



 

4. Grid from TIN 
 
To create a grid from a file containing x,y,z coordinates of points 
 
1. Read the mesh - from the main menu choose: File -> Mesh from a file with points…. 

Select a file you want to use. Files containing points’ coordinates have pts extension. 
It can be “contours.pts” file. The TIN will be created. You can fit it to the screen. You 
can see the TIN in 3d – click “3D view” button. Sometimes in a 3D view the mesh 
doesn’t fit to the screen – you may need to rescale it – type scale value and click 
“scale” button – every z value in the mesh will be multiplied by scale value. 
 

 
 
2. If you want to eliminate flat triangles (assuming that all data is correct): 

a) Skeleton vertices are used to eliminate flat triangles. Before their insertion to 
the TIN elevation values have to be assigned. To do that - from the main menu 
choose: Skeleton Functions - > Estimate Skeleton Vertices Elevation Using 
Radius 

b) Skeleton vertices with assigned elevations have to be inserted into original 
TIN. To do that - from the main menu choose: Skeleton Functions - > Enrich 
TIN with Skeleton 

c) TIN is enriched – flat triangles are removed – see results in 3d (the boundary 
is not anymore rectangular).  

 



    
 
3. Then you can create a grid: 

a) From the main menu choose: File->Save Mesh as grid… It opens a new 
window – “Grid interpolation”: 

 
 

b) Available interpolation methods: 
1. Voronoi cells 
2. Triangle based 
3. Triangle based with slopes 
4. Natural neighbours 
5. Natural neighbours with slopes 
6. Natural neighbours with smoothing 
7. Natural neighbours with slopes and smoothing 
8. Nearest n points (gravity) – set circle radius in the box next to this radio 

button 
9. Modified Shepard’s method – modified gravity interpolation. 



10. Nearest n points with slopes 
11. NEM 
12. NEM with slopes 

c) All values are set up automatically to save the complete current TIN mesh. If 
you want you can save only a part of the mesh – then type boundary values for 
the part of the TIN you want to save (min x, max x, min y, max y). 

d) You can change the step of sampling of the TIN (grid cells size) – step x, step 
y. 

e) Num x, num y – number of grid cells – you can change it too (it updates 
appropriate step automatically). These numbers are used in Genesis II to 
specify the size of the grid. 

f) In the File type group you have a choice of five types of grid files to create – 
USGS DEM grid *.dem, simple ASCII text file *.txt (containing grid z values 
stored in rows), ArcView ASCII file *.asc (containing the header and grid z 
values stored in rows), Ascii XYZ grid file *.xyz (containing x,y,z grid values 
in each line) and ASCII Grid File Format *.grd (format similar to asc but with 
a different header). USGS DEM grids have fixed size 1201x1201 cells, grids 
saved as simple ASCII text files can have different sizes – those TXT files 
can be used in Genesis II to obtain perspective views. 

g) Choose an interpolation method you want to use. 
h) You can rescale every elevation value in the grid also – change scale value. 
i) Confirm – click OK button. It opens a new window – Save grid – choose a 

location for a grid file. The grid is being created and saved at the specified 
location. 

4. You can view grid TXT files using Genesis II software or you can view them in 
3D using this program.  
 
Grids viewing in 3D 
 
The idea is to use grid cells values as data points and to create a TIN from them. To 
do so a grid has to be loaded from file – for this grid a mesh will be created 
automatically, this mesh can be displayed in 3D: 

a) From the main menu choose one of those menu options: Grid-Grid from 
ASCII ArcView grid (*.asc)... Grid-Grid from ASCII GS file (*.grd)..., Grid-
Grid from ASCII TXT file (*.txt).... Choose the grid file 

b) After that the grid is read to the memory and a mesh based on the grid is being 
created. TIN is created from grid cells. All triangles are regular. So as the 
result a mesh with a grid are created. 

  
c) You can display the TIN created from grid in 3D – click “3D view” button.  



 

  
Grid created using triangle based interpolation Grid created using Sibson 

interpolation with slopes 
 

 

To create a grid from the points manually inserted 
 

1. Create new mesh – click TRIANGLE button. Fit it to the screen. 
2. Insert points. To insert a point - switch to “Insert” mode (Ctrl+Right-Click and in 

the small menu choose Insert) and Left-Click at selected location. To delete a 
point – switch to “Delete” mode and then Left-Click to delete selected point. 
Elevation value can be set up for a point by Right-Click in Insert mode and typing 
the z value in the dialog window– this is the current z value which will be 
assigned for inserted points. Every time you can see your current triangulation (*) 
in 3D (**)-> click OpenGL button. 

 

*  **  
3. After points are inserted you can save the mesh as a grid. From the main menu 

choose: File->Save Mesh as grid… Choose interpolation method and click OK. 
4. You can view the resulting grid in Genesis II or in the program (creating a mesh 

from the grid file). 
 



 
 
You can try some different interpolation methods. 
 
 



5. Voronoi Based Runoff Modelling 
 
1. Set the type of mesh to ‘Delaunay for Flow Simulation’. (menu - File-> New Mesh 

Properties). Set also the Disk Radius value to 0.01. 
 

 
 

2. Create a new mesh.  
 

Load the data (menu - File->Mesh from a file with points) - “Open file” dialog 
appears, select “runoff hills1 e frame10.pts” file.  
 
The mesh is created. Switch off Delaunay edges and switch on Delaunay nodes 
displaying. 

 
 

3. Add a Flow Frame around the model.  
 



In the menu open Runoff properties dialog window (menu – Runoff –> Properties..).  

 
Change the ‘z value’ to 10, all flow frame points will have this z value.  
Create a Flow Frame (menu - Runoff -> Add Flow Frame). Flow frame points with 
z=10 are inserted around mesh bounding box. (Separation between flow frame points 
can be changed in the “Runoff properties” window – ‘step x’ and ‘step y’ values).  

 
 
Display the mesh in 3d (click OpenGL button). 
 



 
 
4. Thicken the data.  

Voronoi cells based runoff simulation gives good results when the Voronoi cells 
pattern is regular. Some additional points have to be inserted into the mesh (menu – 
Additional points -> Random Voronoi Pattern). An elevation of those additional 
points can be estimated using various interpolation methods. The interpolation 
method and the number of points to insert have to be specified in “Random Voronoi 
Pattern” dialog window – they can be ‘10000’ and “Natural Neighbours with slopes”. 
 

 
 
After clicking OK additional points are inserted into the mesh. Take a closer look at 
the cells – their shape is not regular.  



 
 

Check number of mesh nodes (Options -> Mesh Info) – should be more than 10000 - 
original data points + flow frame points + random pattern Voronoi points (small 
amount of them was not inserted due to collision with existing nodes)  

 

 
 
The shape is not regular, because the disk size is too small to create a regular pattern 
as a result of random points insertion process. A bigger disk size would result in a 
regular pattern. So, repeat the whole process from the beginning, but before 
creating the mesh change the disk radius from 0.01 to 0.2. (menu - File-> New Mesh 
Properties).  
 
After the mesh is created, the flow frame is added, and random points are inserted 
(insert 50000 points instead of 10000), turn on ‘Disk radius’ displaying and examine 
the Voronoi pattern.  
 



 
 
Check the number of mesh nodes – it should be much less than intended 50000 (+ 
original data + flow frame points) because most of the point was rejected due to collision 
tests. 

 
 
5. Initialize Runoff parameters. Some runoff parameters can be adjusted in “Runoff 

properties” dialog window (Runoff -> Properties). Deafult values which are there can 
be used directly with the mesh created from “runoff hills1 e frame10.pts” dataset. 

 



 
 

The parameters that can be modified are: 
- Initial Water Height – water level put into every Voronoi Cell 
- Time – runoff process time parameter 
- Resistance – runoff process resistance parameter 
- Maximum water height – a value used to scale colour values during flow drawing 

– cells having this or higher water level have dark blue colour. 
- Iterations – number of flow iterations to perform 
- Repaint every n-th iteration – the flow is redrawn every n iteration 
- Flow frame – z values, x and y separation between flow frame point 
Volume of the water and the number of completed flow iterations are displayed there 
also.  

 
6. Initialise runoff – ‘pour’ some water onto the mesh (menu – Runoff->Initialise runoff 

- evenly). The default water level is 0.1. After the water is put onto mesh the screen is 
redrawn with water. (if menu – Runoff -> Draw Runoff menu field is checked) 

 
7. Start Voronoi runoff (menu – Runoff -> Start Voronoi runoff). Specified number of 

iterations is performed, the screen is repainted every n iteration. After iterations are 
finished the process can be continued or started again with different parameters. 

 



  

  
 
 
8. Voronoi based flow process can also be viewed and modelled in the 3D view – click 

OpenGL button. 

 



 
In the 3D view you can display triangles or Voronoi cells, switch between in the ‘display’ 
field. 

 
 
After switching to ‘cells’ mesh with some water should look like below. Click START to 
continue the process in 3D. 
 

 
 
If the mesh type is Delaunay Mesh for Flow Simulation then in the 3D view window an 
additional group of buttons (Runoff group with Properties, Init Runoff, Start…) is 
displayed. 

 
 

To perform the runoff modelling process in 3D the mesh has to be prepared in the 2D 
window first – it has to created, the flow frame added and the data thicken using random 
Voronoi pattern as before. After that the 3D view can be used.  
 

·  To change some runoff parameters click “properties” button, “Runoff properties” 
window will be displayed.  

·  Click “Init runoff” button to ‘pour’ some water onto the mesh.  
·  To start the Voronoi Runoff click “Start” button. 



6. River network – runoff modelling 
 
1. Set the type of mesh to Delaunay Mesh for Flow Simulation. (menu - File-> New 

Mesh Properties). Set Disk size to 0.1, Big Triangle z value to 0. 
2. Create a new mesh. Turn off displaying Voronoi edges and turn on Crust and 

Skeleton edges. 
3. Draw a river network inserting points with elevation = 0 inside the bounding box. 

Make sure crust edges are connected correctly (there cannot be triangles of crust 
edges like in the middle of the first image – in this case add points in the middle of 
appropriate edges). 

 

 

 
4. (OPTION) You can thicken the river data by automatic insertion of points along crust 

edges (menu: Additional Points -> Thicken Points on Crust Edges) 



5. Save the mesh in a file (menu: File -> Save points - *.pts file), name it as ‘river’. 
Later in a case of a problem or making something wrong you can go back to your 
mesh by loading the file. 

6. Set the separation of flow frame points to step x=0.2 and step y=0.2. (menu: Runoff -
> Properties…) 

7. Add a frame to the mesh (menu: Runoff -> Add flow frame). 

 
8. Examine whether the frame points did not beak any of the crust edges of the river – 

in such case remember where the crust is broken, RESET the mesh, load the 
‘river.pts’ file and add more points along the river in places where the crust was 
broken. Add the flow frame again and if the river is correct proceed to the next step, 
otherwise repeat the process. 

9. Change display colours (menu: Options -> Display properties) – Crust-Black, 
Skeleton-Red, set ‘crust and skeleton width’ to 3. Leave Crust and Skeleton display 
only. 

10. Save the mesh in a bitmap in a default directory. (menu: File -> Save mesh in BMP 
file) Name it as ‘river-texture.bmp’. It will be used as a texture later. 

 
11. Add watersheds by inserting skeleton vertices. (menu: Skeleton Functions -> Enrich 

TIN with Skeleton – River Network). Turn off display of all the features (they are 
meaningless now), except Delanay nodes and edges. 



 
12. Display the model in 3D. Turn on edges display. (tick ‘edges’ checkbox) 

 
13. Drape the texture onto the model (menu: File -> Load texture…). Select ‘river-

texture.bmp’ file. Turn off edges display. 

 
14. Add random additional point (menu: Additional points -> Random Voronoi 

pattern…). Set 50.000 points and choose ‘Natural Neighbour + Slopes’ interpolation 
method (tick ‘slopes’ checkbox). Display Delaunay nodes and Voronoi edges only. 



 
15. Display this dense mesh in 3D. Turn off edges display for faster rendering. You can 

drape the texture again. 

  
16. Switch display from triangles to Voronoi cells. 

 
17. Initialize the runoff adding water to the model. (click ‘Initialize’ button) 



 
18. Start the runoff using default parameters. (click ‘Start’ button). You can turn off 

edges display for faster rendering. 

 

 
 
 

 



7. River network - cumulative catchment areas 
 
1. Set the type of mesh to Delaunay Mesh for Flow Simulation. (menu - File-> New 

Mesh Properties).  
 

 
 

2. Create a new mesh.  
Load the data – river1.jpg 

  
Display Delaunay nodes and Voronoi edges 

3. Add a frame around the data 
(menu - Runoff -> Add Flow Frame). Flow frame points with z=0 (Big Triangle 
elevation value) are inserted around mesh bounding box. (Separation between flow 
frame points can be changed in the “Runoff properties” window – ‘step x’ and ‘step 
y’ values).  



 
 

4. Prepare a texture for the 3D model. (turn on Skeleton display first) 
Menu: File -> Save mesh in BMP file… , name the file as “river-texture.bmp”. 

 
5. Select the output point for the process, this node will have the highest cumulative 

catchment area value. 
·  Change the program mode to “Set the outlet for cumulative catchment areas” - 

Ctrl+Right-Click opens the pop-up menu where you must select “Set the outlet 
for cumulative catchment areas” field. In this mode when you move the cursor 
over the mesh the closet data point is being highlighted and the current elevation 
value is displayed in the second part of the Status Bar at the bottom of the window 
– all elevation values for this river data should be equal to 0. 

·  Select the last node of the river – the most bottom one, left-clicking on that point, 
cumulative catchment areas will be computed starting from that node. 



 
6. Add watershed points (menu Skeleton Functions -> Enrich TIN with Skeleton-River 

Network). Additional nodes (skeleton points) will be inserted with elevation values 
automatically estimated. 

 
7. View the model in 3D. Turn on edges display (tick EDGES checkbox). 

 
8. Drape the texture. Select in Menu: File -> Load texture…, select the texture file: 

“river-texture.bmp”. 



 
9. Display cumulative catchment areas. (Menu: Display -> Cumulative Catchment 

Areas) 

 
10. You can start the exercise again with different colours and edges thickness. 

 



8. River network – runoff modelling with an output 
 
1. Set the mesh type to ‘Delaunay Mesh for Flow Simulation’, disk size to 0.09 and load 

river data – river-disk0-09.pts. All nodes have elevation value equal 0. 

 
2. “Estimate crust nodes elevation based on the distance from selected node” – tick this 

option in ‘Skelton functions’ menu and select the starting node, the most bottom 
node, clicking close to it. Set the angle of the slope (use a default 10 degrees angle). 
Elevation values will be assigned to all river nodes automatically. 

 

  
 



 
3. Add a flow frame (menu: Runoff -> Add Flow Frame), using default parameters. All 

the frame nodes will have elevation = 0.  

 
4. Enrich the model (menu: menu Skeleton Functions -> Enrich TIN with Skeleton-

River Network). Additional nodes (skeleton points) will be inserted with elevation 
values automatically estimated. 

 
Visualize it in 3D. 

 
The ridges marked in red have to be deleted and replaced with two horizontal walls, 
separating the output of the river with the outside watersheds. 

5. Delete nodes adjacent to the outlet of the river (marked white below).  



 
Turn the mode to Delete mode (press D key or select Delete from the pop-up menu 
(Ctrl+Right-Click)) and left-click on selected nodes to delete them. 

 
There is a UNDO available for the last deleted point – press “U” key if you deleted a 
wrong point, it will be automatically reinserted. It works only for one point. 

6. Insert new nodes, separating the outlet of the river from the external watershed. 
These should be two strings of points on both sides of the river, all having the same 
elevation. Turn on DISKS display. 
Turn the program to INSERT mode (press I key or select INSERT from the pop-up 
menu). Right click to set the z value for new points. Set z=2.4 for the left row and 
insert points in a line like in the image below. Then set z=2.2 for the right row and 
insert points. All the new points should be close to each other. 



 

 
7. Add more points to the model (menu: Additional Points -> Random Voronoi pattern). 

Set: 30000 points and ‘Natural Neighbours’ interpolation method. Display only 
Delaunay nodes and Voronoi edges. The pattern of nodes due to the relatively large 
disk sizes should be regular. 

  



8. Go to the 3D window. Display Voronoi cells. Initialize runoff. Check the initial water 
volume (menu: Runoff -> Properties), should be around 40. 

 

 
9. Start the runoff process. After clicking START button 10 iterations of the process 

will be performed and the screen will be repainted after each iteration. 

 



10. Check the current water volume. The volume should be the same as at the beginning. 
Notice that the water is cumulating at the outlet. 

 
You can speed up the process by not redrawing the screen every iteration (menu: 
Runoff -> Properties), change ‘number iterations’ from 10 to 100, change ‘repaint 
every n-th iteration’ from 1 to 10. It means the process will be iterated 100 times and 
the screen will be repainted every 10th iteration. 

 
Now we will add some outlet points, so water will no accumulate at the output, but will 
leave the model. This operation can be performed in 2D window only, after that the 
runoff process can be run in 2D or 3D window. 
 
11. Go to the 2D window, Initialise runoff again. (menu: Runoff -> Initialise). Turn off 

Runoff Display in 2D (menu: Runoff -> Draw Runoff) 

 
12. Zoom in to the outlet area bounded by two walls created before. (bottom left corner, 

turn on Altitude display and find a node having z=0 – it is the outlet node of the 
river) 



 
13. Select several cells of the flow frame - they will be the outlet of the river – turn on 

the program to ‘Set Constant Head’ mode (Ctrl+right-click for the pop-up menu of 
press ‘H’ key) and left-click on selected cells, selected nodes will be displayed in 
white colour, and those cells will change their color to gray (no  water). 

 
14. Check the initial water volume and start the runoff process (in 2D or 3D). 

2D – menu: Runoff -> Start 



  
You can switch to the 3D mode at any time and continue the process. 

  
15. Check the current water volume – it should be smaller than the initial value. Notice 

that water is not accumulating at the outlet anymore, it is leaving the model through 
selected cells. 

 
·  Different resistance for nodes 
 
It is possible to specify a different resistance value for cells having a high water level.  
There are two resistance values in the runoff process - the initial resistance and the 
resistance for cells with water level higher than a specified value (let’s call it river 
resistance). Make the river resistance twice smaller than the initial resistance (menu: 
Runoff -> Properties), if the initial resistance was 20 then set the river resistance to 10.  

 
Initialise the process and start runoff.  Water will flow twice faster in cells having a twice 
smaller resistance. 



 
 

  


